Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System Linux
  • Severity High
  • Priority Very Low
  • Reported Version 2.37
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by gerd - 2010-10-02
Last edited by pizza - 2010-10-05

FS#439 - photos not shown after update

Hi,

after update from 2.36 to 2.37 photos are not visible anymore.
The first try of update failed with an error at "DROP OPERATOR ||| (character varying, character varying)". Verifying the staetment on the command line show operator does not exist. After commenting out this line the update was succesfull (no error messages).
No errors are shown postgres or webserver log.

Different behaviour, depended if logged or not:
not logged in: only numbers of photos shown
logged in: after click on number a three available sizes are shown, click on one of them give : "Warning: ini_set() [ref.outcontrol]: Cannot change zlib.output_compression - headers already sent in /home/www/thyscom.ch/po/image.display.php on line 59" whcih is confusing - zlib is available and compress_pages is off

regards, Gerd
(www.thyscom.ch/po)

Closed by  pizza
2010-10-05 16:08
Reason for closing:  Not a bug
Additional comments about closing:  Until next time. :)
gerd commented on 2010-10-03 08:47

retrying the update step by step shows the following error using po.upgrade.2.36.d.to.2.37.a.sql on the following lines:

UPDATE location SET lat_num = latitude::float where latitude != '';
UPDATE location SET lon_num = longitude::float where longitude != '';

ERROR: invalid input syntax for type numeric: ""
LINE 1: ...location set lat_num = latitude::float where latitude != '';
^

Admin
pizza commented on 2010-10-04 17:19

Okay, I'll try to tackle these one at a time.

the '|||' _should_ be there; or at least it was there since before v2.30. I'm not sure what it was actually used for, I don't think it was referenced anywhere in the PO codebase I inherited from Balint. The only reason I can see that line failing is because your DB schema was manually modified at some point (perhaps tracking the -devel version..?). My testing installations all had the operator defined, and using the DROP OPERATOR IF EXISTS syntax will mean we require at pgsql >= 8.2. (Not necessarily a bad thing, as 8.1 EOLs in November)

Admin
pizza commented on 2010-10-04 17:25

Hmm. As for the 'no images' thing, that sounds like there's some sort of PHP wonkiness going on. Are you using an unmodified PO codebase? Is there an extra newline in your config_site.php (or something like that?)

using 'wget' or 'curl' on the command line will show you what's actually coming out of the server, and once we know the extra junk getting prepended, we can sort out why.

Admin
pizza commented on 2010-10-04 17:37

And the same problem of a manually-updated database seems to be responsible for the 'UPDATE location' bug too -- sounds like that stage ofthe upgrade was already complete in your database.

What version of postgresql are you running?

gerd commented on 2010-10-04 17:53

Postgresql is Version 8.4.2-1~bpo50+1 (Debian), the codebase of po is unmodified except config_site.php.
config_site.php is reduced at the moment to:
$site_url
$site_title
$db_dsn
$image_repository_path
$po_options['lang']
$install_enabled = 0;
?>

gerd commented on 2010-10-04 18:10

you got it. extra line was really good point - There was an extra line after the closing ?> tag.
Thank you !

Admin
pizza commented on 2010-10-04 22:14

so.. are there any remaining problems then?

gerd commented on 2010-10-05 15:58

you got it. extra line was really good point - There was an extra line after the closing ?> tag.
Thank you !

gerd commented on 2010-10-05 16:03

no remaining problems now - but not all functions are tested.
Thanks, Gerd

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing