Photo Organizer

  • Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.33-rc3
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by gerd - 2006-12-03

FS#150 - Button "Move to" results in Logout

- uploaded new photos in a new folder
- go to this folder and display the photos
- select one of them, select "Trash" (or another folder)
- press "Move to" results in displaying the logout page (login.php?reason=1) not in moving the selected photo
folder and photos are created/uploaded after installing 2.33-rc3

trying the same on a folder and photo, which exist before updating, the button works as expected (in test folder was only one photo). Reproducable with different browser.

regards, Gerd

Closed by  pizza
2006-12-06 02:23
Reason for closing:  Fixed
Additional comments about closing:  Reported fixed.
gerd commented on 2006-12-03 10:54

same behaviour with "link to" ...

pizza commented on 2006-12-03 13:58

I can't seem to reproduce this on my end -- can you try to recreate it on the demo site? (Goto, Moveto, and Linkto all seem to work)

(I tried both existing photos and just-uploaded-in-just-created folders)

If you are trying to move photos you don't own into or out of a folder you don't own (And you're not the administrator) then that should result in the behaivor you're seeing.

gerd commented on 2006-12-03 15:42

Just created a login on the demo site: tried to create a folder, but this fails - after pressing the "Add"-button I was send to the logout page (tested with epiphany, iceweasel and netscape) ?

If you like to check my site: ...

All folder are owned by myself :-)

Addition: if I move or link the photo in the larger view (not thumbnail) then it works. Hm, just uploaded a photo to a test folder and could move this (by selecting the thumbnail) to trash. But moving back in the same way failed with the described error. The apache errorlog shows the following:

[Sun Dec 3 16:33:17 2006] [error] PHP Warning: pg_query() [<a href=''></a>]: Query failed: ERROR: invalid input syntax for
integer: &quot;&quot; in /home/www/doc/po/folder.content.php on line 244
[Sun Dec 3 16:33:17 2006] [error] PHP Warning: pg_num_rows(): supplied argument is not a valid PostgreSQL result resource in /home/www/doc/po/folder.content.php on line 245

pizza commented on 2006-12-03 15:58

Ah! You found another bug there. I just fixed it (r925); can you try again on the demo site?

Your error log line is interesting -- what PHP rev are you using?

pizza commented on 2006-12-03 16:00

(hold that, I think I figured out what's going on with line 244 etc)

pizza commented on 2006-12-03 16:07

r926 fixes it, I believe, so if you could test out the -demo site and see if you can recreate this problem...

The checkbox handling in the -stable tree is very clunky, and was rewritten in -devel. The permission tests in -devel therefore wouldn't work, so I had to rewrite them for -stable, and I botched it.

I'll put out 2.33-rc4 this evening; enough major errors have hit to warrant another -rc release.

gerd commented on 2006-12-03 16:17

tested on the demo site, unfortunately no change ..

PHP revision on my site is 4.4.4-6 (echo PHP_VERSION)

pizza commented on 2006-12-03 16:55

The folder creation was still broken, but it WorksForMe(tm) now (r928). Please try again? (sorrya bout all of this; as you can tell I usually run as the administrator)

Meanwhile, I can't recreate your original problem (the photo move/link) on the demo site now, as a non-admininistrator.

gerd commented on 2006-12-03 17:21

Ok, now I can create a folder on the demo site. Trying to upload a single jpeg results in:
Importing the Joint Photographic Experts Group JFIF format file dsc_10635.jpg into folder test

* Extracting IPTC data ... done
* Copying dsc_10635.jpg into /home/pizza/public_html/po-stable-demo/_image_repo/v0000/00000/107.jpg
* Preview generation failed.
* /usr/bin/convert -geometry '700x700'\> -unsharp '0.5x0.5+1.4+0.05' -mattecolor '#000000' -profile /home/pizza/public_html/po-stable-demo/im/sRGB.icm +profile icm -colorspace 'RGB' -gamma '1' -quality '85' '/tmp/php3BBeua' '/home/pizza/public_html/po-stable-demo/_image_repo/v0000/00001/107.jpeg'
* Thumbnail generation failed.
* /usr/bin/convert -geometry '170x170'\> -unsharp '0.5x0.5+2.2+0' -mattecolor '#000000' -profile /home/pizza/public_html/po-stable-demo/im/sRGB.icm +profile icm -colorspace 'RGB' -gamma '1' -quality '85' '/tmp/php3BBeua' '/home/pizza/public_html/po-stable-demo/_image_repo/v0000/00002/107.jpeg'
* Cleaning up the mess.

Import finished.

Playing around the error I noticed the following (may be this help): (numbers are the steps)
1. uploading a photo a test folder
2. moving a single photo (selected as thumbnail) from a test folder to trash - works (!?)
3. But moving the same photo back to the test folder results in the desribed error
4. selecting all thumbnails of a page in trash folder and move them to the test folder - works
5. selecting a different number of thumbnails and move them results in a the error
repeat 4) works again

no idea whats going on here - I let's check with rc4 then ;-)

pizza commented on 2006-12-03 17:37

I can't recreate the moving bug at all, to/from trash, it all works.

The add bug you saw -- can you attach the image to this bug ticket? Either it has an embedded ICC profile, or the upload code is mis-detecting it, and doing the wrong thing -- as my local ImageMagick doesn't support ICC conversions so it errors out.

I won't be able to work any more on this until possibly tomorrow, but we'll see.

gerd commented on 2006-12-03 17:49

the image should be attached, it's a jpeg created by BibblePro from a raw (Nikon D70)

pizza commented on 2006-12-04 19:08

Okay, the image does have an embedded ICC profile, so the import code is doing the right thing -- it's just that the demo site's ImageMagic installation can't handle ICC colorspace conversions (yet).

pizza commented on 2006-12-04 21:26

Okay, the ImageMagick installation has been recompiled to use lcms. I tested the image you attached, and it also imported properly.

gerd commented on 2006-12-04 21:54

Ok, just tested on the demo site - "move to" works as normal.
Hmmm, no idea, what's the problem on my site ... I'll install rc4 probably tommorow ..
Let's see what happens ;-)

best regards, Gerd

gerd commented on 2006-12-05 19:00

Solved with rc4.


Available keyboard shortcuts


Task Details

Task Editing