Photo Organizer

This is the bug tracker for Photo Organizer.

ID Task Type  asc Severity Category Summary Status Reported In
 106 Bug ReportCriticalBackend / Core Install creates wrong directory structure in repository Closed2.32a5 Task Description

When installing photo organizer 2.32a on a clean system (so not an upgrade) the driectory structure in the repository is set up wrong. The 0000x folders are not created in the v0000 folder, but next to the folder at the root of the repository.

Where the structure should be:

<path-to-repository>/photoorganizer
/v0000
/00000
/00001
/00002

it is created as

<path-to-repository>/photoorganizer
/v0000
/00000
/00001
/00002

 108 Bug ReportCriticalBackend / Core Registering a new user is broken Closed2.32b1 Task Description

Fresh install, I get the following error when creating a simple user (just filling in mandatory fields, the bold ones)

Warning: pg_query() [function.pg-query]: Query failed: ERROR: column "f" does not exist in /var/www/localhost/htdocs/po/register.php on line 176

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 199

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 206

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 213

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 221

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 227

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 231

Warning: pg_query() [function.pg-query]: Query failed: ERROR: current transaction is aborted, commands ignored until end of transaction block in /var/www/localhost/htdocs/po/register.php on line 235

Warning: Cannot modify header information - headers already sent by (output started at /var/www/localhost/htdocs/po/register.php:176) in /var/www/localhost/htdocs/po/register.php on line 251

Stange as it works fine with my version of 2.32a on another machine. Could this be a database issue?

 112 Bug ReportCriticalBackend / Core Bug in bulk update Closed2.32b1 Task Description

I tried to change the Author and Copyright fields of all photos of a user.

Bulk update doesn't update the fields, it give the following result:

# author = 'Bjorn Dejonghe', copyright = 'Copyright (c) 2006 Bjorn Dejonghe'
# users = 6

Warning: pg_query() [function.pg-query]: Query failed: ERROR: column "copyright" of relation "photo" does not exist in /var/www/localhost/htdocs/po/bulk.update.php on line 261

Updated 602 photos.

 140 Bug ReportCriticalUser Interface Web installer fails to recognise $install_enabled Closed2.33-rc21 Task Description

As noted on #po-devel:

Web installer always says "Install disabled. please set $install_enabled=1 in config_site.php if you wish to run the installer." regardless of $install_enabled setting in config_site.php.

FIX:

install.php, lines 477-480 is the check if $install_enabled is 1, but you're not actually including the config file(s) until line 489, so $install_enabled is unset.
Move lines 477-480 (the check for $install_enabled != 1) to after line 489.

 290 Bug ReportCriticalImport Invalid upload path Closed2.34-rc42 Task Description

Php files are in /usr/share/photo-organizer/ directory
In config_site.php i set:
$image_repository_path = "/home/services/photo-organizer/repo/";
And when i try to upload image i get:
# xtracting Image Metadata (EXIF) ... done
# Extracting Image Metadata (XMP) ... done
# Extracting Image Metadata (IPTC) ... done
# Copying original image siamki.jpg into repository ... failed.
#

cp /tmp/phpEUVYLs /home/services/photo-organizer/repo///usr/share/photo-organizer/v0000/00000/7_3_orig.jpg

# Cleaning up the mess.

it seems that $new_volume="/usr/share/photo-organizer/v0000/" but i dont know why

 330 Bug ReportCriticalImport Import of big images fail. Closed2.3511 Task Description

I try to import an image larger than 10 Mb. The result is the same for all images larger than 10 Mb

The image is not imported and the result is as follows.

Importing 'DSC_1803.NEF' (Nikon Raw Format) into folder Testing.

* Extracting Image Metadata (EXIF) ... done
* Extracting Image Metadata (XMP) ... done
* Extracting Image Metadata (IPTC) ... done
* ERROR: current transaction is aborted, commands ignored until end of transaction block
* Failed to update database.
*

insert into photo
(identifier, users, folder, location,
caption, date_of_exposure, access_rights, copyright_statement,
views, hide_original, author, title,
caption_writer, category, credit, source,
headline, instructions, transmission_reference,
supplemental_category, web_statement, store_url, comments)
values (748, '2', '12', 0,
'', '2007-12-23 15:59:29', '1', 'Copyright (c) 2008 Rolf Cronberg',
0, 't', 'Rolf Cronberg', 'ERIK CRONBERG',
'', '', '', '',
'', '', '',
'', '', '', '')

* Cleaning up the mess.

All images imported.

 366 Bug ReportCriticalItalian Registration/Confirmation mail doesn't arrive correctly Closed2.35 Task Description

Registration Mail doesn't arrive correctly. Username and PASSWORD are not provided.

The bug is on the 761 and 762 line of src/lang/it_IT.php

You have to replace:

$user_data[3] with $user_data[username]
and
$user_data[4] with $user_data[password]

Bye!

 384 Bug ReportCriticalDatabase PO does not create database tables on remote PostgreSQL ...Closed2.365 Task Description

everything looks fine until the PO's setup script trys to import the tables to the pgsql server. I am unable to proceed with the setup. No documentation for remote pgsql server only local server. po_user is able to connect manually but not install.php is not able to.

 409 Bug ReportCriticalWeb site Demo/Test Site Delivers empty page after valid login ClosedDevel2 Task Description

Try to login with invalid account credentials. Correct behaviour, displays invalid login.

Try to login with valid credentials (created account in Flyspray bugtracker, as indicated in into page). Accepts credentials, but lands on an empty page. Displaying the source of the delivered page proves no content delivered.

Users Page and help page seem to work ok.

Clicking "Folders and Albums" in Search results in a "404 Not Found" error.

Demo site is apparently rather broken at the moment.

 410 Bug ReportCriticalInstaller Password displayed instead of database during install w ...Closed2.36 Task Description

If attempting to run "install.php" without a language, then the output includes the line:

"su - postgres -c "createlang plpgsql <password>"

<password> is the password, unmasked. It should be <database>.

The problem was a single "=" instead of a double "=". I have attached a diff file with the fix. The line numbers seem off though, compared to what grep says.

 466 Bug ReportCriticalBackend / Core Original photos deleted without adding to database on d ...Closed2.371 Task Description

Hello,

I'm having a problem with writing to my database, but reads are fine. I am adding images from a local directory. I am using PO 2.36.1.

When I try to add images, I get red text telling me that the transferring the metadata failed and that PO failed to update the database. Unfortunately, PO still goes ahead with "cleaning up the mess".

Luckily I still have a backup of my photos, but this part of the process could probably use some extra checks and an abort before deleting the files.

Thank you,

Jeff

 18 Bug ReportHighBackend / Core Stop using predictable filenames ClosedDevel4 Task Description

For things like photo imports, exports, and whatnot, we use predictable sequences in our filenames. These should be properly randomized.

 113 Bug ReportHighBackend / Core camera edit doesn't respect owner ClosedStable7 Task Description

someone can edit a camera they don't own.

 158 Bug ReportHighBackend / Core AND in search for keywords does not work ClosedStable3 Task Description

Searching for 2 keywords linked with AND always gives back an empty result.
Eg.: I have 2 images that both have the keywords "abstract" and "art" attached to them. They can't be found by the search "abstract AND art".

Looking at the SQL that PO sends to the database, I could trace the error. The search above produces the SQL:

[...]
OR photo.identifier in (select k.photo from photo_keywords k where (k.keyword ~* 'abstract' and k.keyword ~* 'art'))
[...]

This seems to be wrong since k.keyword contains only ONE keyword at a time. So "k.keyword ~* 'abstract' and k.keyword ~* 'art'" will never find a corresponding line in the database.

The SQL-part about keywords should be

photo.identifier in(select k.photo from photo_keywords k where k.keyword ~* 'abstract') and photo.identifier in(select k.photo from photo_keywords k where k.keyword ~* 'art')

The "AND" must be between the two "in(select... )"-Subqueries, not in them.

The problem in the code is in search.text.general.php, line 160, where a string plus the build_sql_search_string-function are used to generate $sql_search_keyword. I would suggest to write a new function, which is the same as build_sql_search_string() exept the part that handles "AND". This should be something like:

elseif (strncmp($keyword[operator], "AND", 3) == 0) {
if ($sql_search_string == "")
$sql_search_string = "photo.identifier in (select k.photo from photo_keywords k where " .sprintf("%s %s", $sql_field_name, $keyword[keyword]);
else
$sql_search_string .= " and photo.identifier in (select k.photo from photo_keywords k where " .sprintf("%s %s", $sql_field_name, $keyword[keyword]).")";
}

In line 160 in search.text.general.php ")" should be added to the return of this new function at the end, but no text at the beginning.
That should fix the simple search.
I have not investigated into the complex search, which doesn't find keywords linked by "AND" either.

 193 Bug ReportHighBackend / Core figure out why e-mail templates are broken. ClosedDevel Task Description

They're not getting evaluated properly.

 240 Bug ReportHighBackend / Core "Empty trash" broken in r1539 ClosedDevel Task Description

"Empty trash" appears effectively broken now (Release trunk, r1539)

Whether in main listing, or in the Trash folder listing, the page appears to be blank.
In the error-file there is a notice:

Function name must be a string in /var/www/po.bugslayer.de/html/trash.empty.php on line 52, referer: http://po.bugslayer.de/folder.php?folder=1

Kind of showstopper :-O

 311 Bug ReportHighInstaller fresh install hangs on sql/db error Closed2.3412 Task Description

Hi, I was doing a new install 2.34b from scratch on a OpenSuse 10.0. Following the install guide, then calling po/install.php. Result:

[...]
Upgrading from Photo Organizer version 2.33

* Upgrading database structure...OK
* Upgrading database data...

-- FAILED: update folder set date_changed = (select max(date_of_creation) from folder f2 where f2.parent_folder = folder.identifier) where date_changed is null

FAILED
*

FEHLER: could not open relation with OID 23434
CONTEXT: SQL-Anweisung »SELECT 1 FROM ONLY "public"."users" x WHERE "identifier" = $1 FOR UPDATE OF x«

No idea what that could be...

 334 Bug ReportHighBackend / Core cannot delete users that have folder/album thumbnails s ...ClosedDevel4 Task Description

via the admin.user.del pages.

the problem is due to a dependency.

 335 Bug ReportHighImport Non-ASCII/UTF-8 files are failing to import properly. ClosedDevel3 Task Description

I have two files here, generated by photoshop, with special ISO8859-1 characters.

We need to be able to convert all of these strings into a UTF-8 format for DB insertion.

 387 Bug ReportHighJavascript Internet explorer 7 and add keywords Closed2.361 Task Description

There is a problem with javascript (I suppose) in ie7 when I go to add the keywords (photo.add.php?folder=3).

 389 Bug ReportHighBackend / Core cannot edit any photo Closed2.361 Task Description

When i try to edit any photo (click on album name, then the photo i want to edit, choose 'edit') - i.e. add keyword - after all the modifications are done, click on 'Save changes' and nothing appens. Reading the log i've found:
[error] [client 127.0.0.1] PHP Fatal error: Call to a member function delete() on a non-object in /var/www/html/po/photo.edit.2.php on line 175, referer: http://localhost/po/photo.edit.php?photo=1&album=

Tried on a fedora core 8 and debian testing (pgsql 8.2.9, php 5.2.6)

Thanks,
Giovanni

 392 Bug ReportHighUser Interface Edit on a single photo fails Closed2.362 Task Description

Select a single photo from an album and hit the 'edit' button at the bottom. URL is now:

po/photo.edit.php?photo=10&album=

change info in the fields, add new tags etc... Hit 'save changes'.

Get back a blank response (HTML source is empty). URL is now:

po/photo.edit.2.php

Go to the photo page, refresh if necessary, edits have not been saved.

Workaround: select a single picture and use the 'Bulk Update' with that picture. Works.

Note - on the Bulk Update page the fields all have a checkbox for you to mark the changes you want. On the photo.edit.php page there are no checkboxes...

Very recent apache2/postgres/ubuntu installation, seems to happen for all users.

thx

 405 Bug ReportHighUser Interface mail.php not included by subscription.add.php Closed2.36 Task Description

subscription.add.php doesn't include the mail.php include, and so fails to send client notifications. Adding:

include_once "include/mail.php";

after the other includes fixes this.

 430 Bug ReportHighJavascript BASE tag not working properly with Internet Exporer Closed2.36 Task Description

as of this writing, it works with a fully-patched IE8 for <a href> links, but stuff specified in javascript (eg location.href = or location.assign()) doesn't respect the BASE HREF tag at all.

This is a fundamental IE bug.

see http://www.theogray.com/c9/base_href.htm

and also http://channel9.msdn.com/wiki/wiki/InternetExplorerProgrammingBugs/

At the moment, this breaks a few buttons in PO only -- list/slide view, and edit/delete buttons -- all on the photo view page.

Not sure how to go about working around this, except to not use pretty URLs...

 435 Bug ReportHighBackend / Core Security problem: world readable files in /tmp (and may ...Closed2.363 Task Description

I've noticed that in various situations, Photo Organizer creates files in /tmp.
These have loose permissions due to an inadequate umask.

What's the point of Alice making her pictures private, so that Bob can't
see them, if Bob has a shell account on the box and can see Alice's
data as it passes through /tmp?

My /var/lib/photoorganizer-data directory behaves the same way.
Everything under that is rwxr-xr-x or rwxr--r--.

The data is correctly owned by the apache user account (www-data
in my installation) but files should should be rw-------,
and directories and rwx------.

Is this something that can be done globally with PHP or some Apache2
umask setting?

 439 Bug ReportHighBackend / Core photos not shown after update  Closed2.379
 449 Bug ReportHighUser Interface PHP can no longer find site_navigator() Closed2.372
 72 Bug ReportMediumBackend / Core Upload of rotated jpg images appear upside down Closed2.292
 86 Bug ReportMediumBackend / Core TYPO ALERT ClosedStable1
 90 Bug ReportMediumBackend / Core Times are lost when editing an image's details. Closed2.31a2
 92 Bug ReportMediumBackend / Core Adding a folder failed Closed2.31a5
 96 Bug ReportMediumBackend / Core Register a nnew user failed Closed2.31b2
 107 Bug ReportMediumUser Interface index.php is missing site_prolog() call Closed2.32b
 109 Bug ReportMediumBackend / Core SQL error from tools.php Closed2.32b1
 116 Bug ReportMediumBackend / Core GROUP is reserved word in PostgreSQL ClosedDevel1
 136 Bug ReportMediumBackend / Core move to folder from folder view not working ClosedDevel
 139 Bug ReportMediumBackend / Core Unable to logout ClosedStable
 142 Bug ReportMediumUser Interface "Invalid login" when you haven't attempted a login Closed2.33-rc22
 156 Bug ReportMediumUser Interface Admin interface not working Closed2.331
 198 Bug ReportMediumBackend / Core Bug in SQL functions count_equipment_by_user and number ...Closed2.33
 207 Bug ReportMediumBackend / Core ould not create new user entry, database error -- New i ...ClosedDevel25
 211 Bug ReportMediumBackend / Core Fields cannot be updated for a single picture ClosedDevel8
 212 Bug ReportMediumRendering Buttons look weird in devel r1328 ClosedDevel9
 220 Bug ReportMediumDatabase 'Pentax *dst' as a camera type fails due to regexp erro ...Closed2.331
 228 Bug ReportMediumBackend / Core Cannot import NEF raw when orientation is portrait Closed2.34-rc18
 248 Bug ReportMediumBackend / Core Clear Keyword broken in bulk update Closed2.34-rc3
 260 Bug ReportMediumBackend / Core "Clear Keyword": Typo in "bulk.update.php" Closed2.34-rc3
 271 Bug ReportMediumBackend / Core PHP Timeout on bulk updates with watermarking Closed2.34-rc323
 293 Bug ReportMediumInstaller installation issue Closed2.348
 322 Bug ReportMediumBackend / Core 'transfer metadata' isn't working for RAW images. Closed2.35
Showing tasks 1 - 50 of 448 Page 1 of 9

Available keyboard shortcuts

Tasklist

Task Details

Task Editing