Deprecated: Function create_function() is deprecated in /var/www/flyspray/includes/class.flyspray.php on line 113 Deprecated: Function create_function() is deprecated in /var/www/flyspray/includes/class.user.php on line 115 FS#91 : XML 'title' not being imported properly.

Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To
    Solomon Peachy
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.31a
  • Due in Version 2.33
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by Solomon Peachy - 2006-08-30
Last edited by Solomon Peachy - 2006-09-07

FS#91 - XML 'title' not being imported properly.

I've re-run the same XML with the corrections and it's imported fine,
however one last thing - the "title" tag of the photo is not read in.
I've tried it as <photo title="(title)"> and
<photo><title>(title)</title></photo> - but the latter fails the
integrity checks (presumably as it's incorrect according to the DTD),
and the former is just ignored.

<photo title="Christmas tree!"> ??

Closed by  Solomon Peachy
2006-09-07 02:37
Reason for closing:  Fixed
Additional comments about closing:  Short-term fix is in; long-term has a new bug ticket (97)
Deprecated: Function create_function() is deprecated in /var/www/flyspray/includes/class.user.php on line 115 Admin
Solomon Peachy commented on 2006-09-04 20:43

It's not a bug in the XML code. Basically, the EXIF data is overriding the XML data.

(The EXIF data in this case appears to have a null UserComment field)

I'm not sure how to handle this; there are many use cases.

Photo upload defaults get overridden by XML Data which gets overridden by EXIF/IPTC/XMP.

I think the best possibility is to make XML data selectable in the import order, but that's a fairly invasive change.
Other possibilities include adding a toggle to ignore EXIF UserComment data, either on a per-camera basis or per-import basis.

Deprecated: Function create_function() is deprecated in /var/www/flyspray/includes/class.user.php on line 115 Admin
Solomon Peachy commented on 2006-09-07 02:27

I'm checking in a kludgy-fix for this. If there's a TITLE in the XML Data, we ignore the EXIF UserComment field.

The IPTC/XMP importers are also kind of broken. Sigh. All of this needs to be properly handled.

fixed in r545 (Stable), r546(devel)

Deprecated: Function create_function() is deprecated in /var/www/flyspray/includes/class.user.php on line 115 Admin
Solomon Peachy commented on 2006-09-07 02:28

I'm making this due later; a proper fix will take much longer.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing