Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category Backend / Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.30
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by Markus - 2006-06-26

FS#79 - ability to make the original photo available to the public

hi!

imagine you take "free shot" and you want to give the away to the public. for me such a feature would be nice to have, since want to use po for sharing pictures with friends and everyone who likes them.

thank you
markus

Closed by  Solomon Peachy
2006-06-26 21:42
Reason for closing:  Not a bug
Additional comments about closing:  feature already exists.
Admin
Solomon Peachy commented on 2006-06-26 21:29

So, you essentially want a third access rights category for the original images:

* owner
* authorized users
* everyone

That's easy enough to add. It certianly demonstrates one of the weaknesses in the existing permission model.

Admin
Solomon Peachy commented on 2006-06-26 21:41

Okay, upon further checking, this is already possible.

When you are importing or editing an image's metadata, you can select the access rights (public/private/protected) and also the "high resolution original" settings (owner only/authorized users). "authorized" in this case means that anyone who can view the preview image can also download the original image.

So if an image is marked "public" and "authorized users" anyone can download the original image.

It gets more complicated when we're talking about the shopping cart system and registered clients, but what you want already exists.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing