Gutenprint / CUPS Dye-sublimation drivers

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Mitsubishi CP-Dxx family
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version 1.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Gutenprint / CUPS Dye-sublimation drivers
Opened by Solomon Peachy - 2020-02-07
Last edited by Solomon Peachy - 2020-02-27

FS#642 - Faint yellow-ish bands visible on a predominantly white background

Does not happen on the official Mac drivers, but Gutenprint + lib70x shows it.

Best guess is that we have an inverted sign or off-by-one error in a compensation function that's causing the yellow channel to not get scaled correctly.

Closed by  Solomon Peachy
2020-02-27 00:55
Reason for closing:  Fixed
Additional comments about closing:  Found a couple more logic errors, and the one that I believe is responsible for the artifacts -- the wrong structure was initialized at the start of the image processing.
Admin
Solomon Peachy commented on 2020-02-08 15:56
So far I found one logic error (a '< 0.0' instead of '<= 0.0') that didn't seem to affect the output at all. Also found a couple of discrepancies between the decompiled x86 and PPC code. Only one seems to be a logic related so far (X = A + B - C - D on PPC, and X = A + B - C + D on x86) Will have to put this aside for a few days due to RealLife though.
Admin
Solomon Peachy commented on 2020-02-13 19:47
That discrepancy was a red herring. Found no other logic bugs so far, though I have made some readability improvements to the code.
Admin
Solomon Peachy commented on 2020-02-15 01:28
Found a minor bug in the sharpening line copy code, but it only affected head/tailroom, and not the image data itself (at most it affected the leftmost and rightmost three pixels, usually lost due to full-bleed anyway) But even disabling sharpening doesn't seem to have any effect on the artifacts, so that doesn't matter anyway.,
Admin
Solomon Peachy commented on 2020-02-20 02:39
Does not occur with CP-D80 (with identical settings) so the problem is not Gutenprint's rendering. Could still be the library, due to a difference in data tables between the two models?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing