Photo Organizer

Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category User Interface
  • Assigned To No-one
  • Operating System Linux
  • Severity Medium
  • Priority Normal
  • Reported Version 2.36
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Photo Organizer
Opened by Eckhard Doll (doll1) - 2009-11-03
Last edited by Solomon Peachy (pizza) - 2013-08-21

FS#426 - Cross Customer Relations

I'm not really handling customer relations with po, I'm just using this limited permission model not to expose all pictures to anybody from the www.

So I use protected-level to make my family or trusted users (in this circumstance) able to look at some more pictures than others. Just for me this works perfect. As I like to offer this functionality to others also, it comes to trouble (I think). At least it becomes more complicated.

If I like to add a customer who is already registered as a user, I have some handy buttons on user-page to accomplish this mission. Like that. If, in turn, this user would like to add me as his customer... information about his clientness but no buttons, just contact information if he clicks on my user-name.

I'm not shure if I could clear the point, please ask.

Regards

This task does not depend on any other tasks.

Closed by  Solomon Peachy (pizza)
Wednesday, 21 August 2013, 00:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Never got useful feedback.
Solomon Peachy (pizza)
Thursday, 12 November 2009, 18:52 GMT
Question -- are these other users "client" users or are they full-fledged users? (ie can upload their own images etc)

If I understand what you are saying correctly

U1 is a client of U2
U2 wants to be a client of U1, but no buttons show up, only contact info for U1.

I believe this is happening because U2 is an admin account. Subscriptions are disabled if the user is an admin, because they have access to everything anyway.
Solomon Peachy (pizza)
Wednesday, 03 March 2010, 19:25 GMT
I never got an answer, and I'm trying to close out bugs and other misc stuff so I can get v2.37 out the door.

Loading...