Photo Organizer

Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core → Import
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Normal
  • Reported Version 2.36
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Photo Organizer
Opened by Jeff Robins (jeffrobins) - 2009-06-29
Last edited by Solomon Peachy (pizza) - 2009-07-06

FS#413 - empty folders are not deleted when using local bulk upload

If one is using local bulk upload and the local path includes directories with photos in them, then the photos in the directories are added relative to the upload folder as designed and all of the uploaded photos are deleted. However, the, now empty, directories still exist.

Ex:
1) Do local bulk upload from a directory, "/upload/".
2) Place one photo, called "1.jpg" in the upload directory, "/upload/1.jpg".
3) Place a second photo in a directory with the upload directory, "/upload/nested directory/2.jpg"
4) 1.jpg is imported in the specified folder and 2.jpg is imported into a folder called "nested directory" in the specified folder.
5) 1.jpg and 2.jpg in the "/upload/" directory are deleted.
6) Empty folder "/upload/nested directory/" is not deleted and will be added to future imports unless deleted manually.

This task does not depend on any other tasks.

Closed by  Solomon Peachy (pizza)
Monday, 06 July 2009, 18:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  I'm going to close this. PO now does all it can to remove the temp directories on imports; if it can't, it's because of a permission problem.
Solomon Peachy (pizza)
Monday, 29 June 2009, 15:34 GMT
you're right, the "remove subdirectories" code is disabled for local imports; I think what happened was that the top-level import directory was also being erased.

Oneof the problems of local filesystemimports is taht the web server often does't have permissions to manipulate/remove directories owned by other users, and vice versa..

the 2.37-rc series has a similar problem, though for entirely different reasons.
Solomon Peachy (pizza)
Saturday, 04 July 2009, 16:32 GMT
Okay, I just added code to properly clean up tempdirs on imports. It'll be in the next release.

Loading...