Photo Organizer

Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category User Interface
  • Assigned To Solomon Peachy (pizza)
  • Operating System All
  • Severity Low
  • Priority Normal
  • Reported Version 2.36
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Photo Organizer
Opened by Eckhard Doll (doll1) - 2008-09-12
Last edited by Solomon Peachy (pizza) - 2008-09-16

FS#380 - Another one

When I change folder settings from the folder view (not from the folder list), let's say to add something to the description, the click on the save button saves changes but moves me to the parent.

This task does not depend on any other tasks.

Closed by  Solomon Peachy (pizza)
Tuesday, 16 September 2008, 00:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  It should be fixed now.
Solomon Peachy (pizza)
Friday, 12 September 2008, 12:57 GMT
This was introduced when I merged the folder add/edit/delete pages to take advantage of common code.

The problem is that there are two paths that can take you to the folder edit page.

now should the 'add' page take you to the new (empty) folder, or to that folder's parent?
Solomon Peachy (pizza)
Friday, 12 September 2008, 14:20 GMT
http://git.shaftnet.org/git/gitweb.cgi?p=po.git;a=commitdiff_plain;h=2b0f66d29a02b5505bd3aca96577071bcbaabaa2

Try this patch.

And apparently I never actually merged the folder/album add/edit/delete pages like I'd merged so many others.
Eckhard Doll (doll1)
Friday, 12 September 2008, 14:44 GMT
My point is, when I go from somewhere to change something, pressing the save button should either leave me where I am or put me where I left. Should not put me elsewhere.

To answer your question I give you a sketch of my usual workflow inside po.
At first I import the whole CF-Card into a folder called 'import'.
Inside the database all photos are organized in folders called 'yyyy-mm', in every folder the pictures I took that month.
So I enter 'import', link some pictures to existing albums and move them based on creation-date to their destination folder.
Some times in the process I need another album or a new folder.
So, for my purposes, it would be really convenient, at first, to be put where I left either way I come, and second, even to have an add-(folder|album)-button on the preview page.

Any more questions?

Could it be possible to give the add/edit/delete page a hint where it should throw the visitor afterwards?
Solomon Peachy (pizza)
Friday, 12 September 2008, 14:54 GMT
I've been adding hints to try and improve the flow; 2.36 is a lot better than older releases in that regard. Of course, there's a ton of work to be done still. That first patch is wholly inadequate, but I'll add some more hints so that we can return to the previous[-1] page.
Solomon Peachy (pizza)
Friday, 12 September 2008, 18:54 GMT
Okay, here's a second commit that should take care of the problems with edit/delete/add folder/album not returning to the originating place.

http://git.shaftnet.org/git/gitweb.cgi?p=po.git;a=commitdiff_plain;h=a783bea41f076900b011223b8832850708a05c0a

It applies on top of the one posted earlier.
Eckhard Doll (doll1)
Saturday, 13 September 2008, 11:27 GMT
Solomon,

I think I never got such quick and friendly feedback, discussions and even fixings like from you on po and I appreciate very much but do yourself a favour not to waste your valuable time creating patches for me. As, if it's not that fatal I will wait for the next regular update.

As I am also a programmer (and father since June, 15th), I almost imagine how much of your free time (if there's any) you spend on the project and I wonder what your wife thinks about.

But thank you very much anyway.
Solomon Peachy (pizza)
Saturday, 13 September 2008, 19:52 GMT
It's nice to be appreciated!

Hacking on PO generally helps to clear my head, but the bottom line is that PO is highly useful for me, even if nobody else uses it. Features that others suggest that I can use myself tend to be implemented quicker than things that I personally will never use.

Congratulations on parenthood. I imagine you get a lot less sleep now..

Loading...