Photo Organizer

Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Normal
  • Reported Version Devel
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Photo Organizer
Opened by Marcus Hinz (marcus) - 2008-04-27
Last edited by Solomon Peachy (pizza) - 2008-05-01

FS#350 - Edit of "My Profile" doesn't work

If I try to edit for example the cameras in my profile I get an error "update database failed" (same for lenses and supports, the other things aren't tested by me).

At your devel demo site no error occurs but the things aren't updated.

This task does not depend on any other tasks.

Closed by  Solomon Peachy (pizza)
Thursday, 01 May 2008, 15:33 GMT
Reason for closing:  Not a bug
Additional comments about closing:  I'll tweak the page so that it's less confusing, but I'm glad there's no bug.
Solomon Peachy (pizza)
Monday, 28 April 2008, 15:36 GMT
Just to confirm -- you're trying to edit an existing camera, right?
Marcus Hinz (marcus)
Monday, 28 April 2008, 18:06 GMT
Yes, I do. I'm trying to edit a existing camera, a lens or something else...
Solomon Peachy (pizza)
Tuesday, 29 April 2008, 00:32 GMT
[lens, scanner, support, flash, filter] edits were broken as they used the same set of forms. It's a one-line fix in r2031.

Cameras, on the other hand, appear to work just fine, at least with my testing of the demo site.

Can you confirm that r2031 fixes your problems?
Marcus Hinz (marcus)
Tuesday, 29 April 2008, 04:38 GMT
I've tested a bit...

At your devel site:

Editing of the model name of lenses, cameras!, supports doesn't work. No error but the new model name isn't saved. Editing the serial number works.

At my site:

All editing results in a "Failed to update database."-error.
Solomon Peachy (pizza)
Thursday, 01 May 2008, 13:46 GMT
I still can't recreate this -- I successfully edited a camera and a lens; I changed both model name and serial numbers.


...Are you properly selecting the 'edit a camera type' radio button? (I should add some javascript to automate this)

Marcus Hinz (marcus)
Thursday, 01 May 2008, 14:43 GMT
Your are right. I didn't do this! I really think you should some javascript (especially for me) :-)

Loading...