Photo Organizer

Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core → Import
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Normal
  • Reported Version 2.35
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Photo Organizer
Opened by Rolf Cronberg (rolfcronberg) - 2008-02-17
Last edited by Solomon Peachy (pizza) - 2008-02-18

FS#330 - Import of big images fail.

I try to import an image larger than 10 Mb. The result is the same for all images larger than 10 Mb

The image is not imported and the result is as follows.

Importing 'DSC_1803.NEF' (Nikon Raw Format) into folder Testing.

* Extracting Image Metadata (EXIF) ... done
* Extracting Image Metadata (XMP) ... done
* Extracting Image Metadata (IPTC) ... done
* ERROR: current transaction is aborted, commands ignored until end of transaction block
* Failed to update database.
*

insert into photo
(identifier, users, folder, location,
caption, date_of_exposure, access_rights, copyright_statement,
views, hide_original, author, title,
caption_writer, category, credit, source,
headline, instructions, transmission_reference,
supplemental_category, web_statement, store_url, comments)
values (748, '2', '12', 0,
'', '2007-12-23 15:59:29', '1', 'Copyright (c) 2008 Rolf Cronberg',
0, 't', 'Rolf Cronberg', 'ERIK CRONBERG',
'', '', '', '',
'', '', '',
'', '', '', '')

* Cleaning up the mess.

All images imported.

This task does not depend on any other tasks.

Closed by  Solomon Peachy (pizza)
Monday, 18 February 2008, 15:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  r1916.
Solomon Peachy (pizza)
Sunday, 17 February 2008, 12:50 GMT
What's your max upload filesize and max POST size? On the photo upload page, it lists the max size ("Maximum upload file size: 300M")

ALso, your web server may be configured to limit the max size too.

I routinely upload a couple hundred megs at once; and indeed many of my individual images are over 10M.
Rolf Cronberg (rolfcronberg)
Sunday, 17 February 2008, 16:40 GMT
My max upload size is 400 M

I get the same result on your demosite for the stable version. It seem to be related to the database transaction.

Importing 'DSC_1803.NEF' (Nikon Raw Format) into folder test.

* Extracting Image Metadata (EXIF) ... done
* Extracting Image Metadata (XMP) ... done
* Extracting Image Metadata (IPTC) ... done
* ERROR: current transaction is aborted, commands ignored until end of transaction block
* Failed to update database.
*

insert into photo
(identifier, users, folder, location,
caption, date_of_exposure, access_rights, copyright_statement,
views, hide_original, author, title,
caption_writer, category, credit, source,
headline, instructions, transmission_reference,
supplemental_category, web_statement, store_url, comments)
values (872, '417', '859', 0,
'', '2007-12-23 15:59:29', '1', 'Copyright (c) 2008 Rolf Cronberg',
0, 't', 'Rolf Cronberg', 'ERIK CRONBERG',
'', '', '', '',
'', '', '',
'', '', '', '')

* Cleaning up the mess.

All images imported.

With best regards
Rolf Cronberg
Solomon Peachy (pizza)
Sunday, 17 February 2008, 16:54 GMT
Odd. I imported a NEF this morning. Granted, it was only 9.4M.

Can you attach the file you're using, so I can watch the logs when I upload it?
Solomon Peachy (pizza)
Sunday, 17 February 2008, 17:00 GMT
The problem isn't the size of the file.

The ISO value in the file is 'Hi 3200' -- since we treat it as a numeric value, the DB chokes.
Solomon Peachy (pizza)
Sunday, 17 February 2008, 17:03 GMT
The attached patch (commtted in r1913) will solve the import failing, but the ISO isn't properly imported yet.
Rolf Cronberg (rolfcronberg)
Sunday, 17 February 2008, 17:12 GMT
Ok, So what are the solution,

I can change the ISO value manually, but what would you say about the future. Maybe it shouldn't be a numeric value In this case it come from a Nikon D80.
Rolf Cronberg (rolfcronberg)
Sunday, 17 February 2008, 17:32 GMT
I've tried the patch but it doesn't solve the problem

Errormessage changed to

2008-02-17 18:25:12 CET ERROR: invalid input syntax for integer: "Hi 3200"
2008-02-17 18:25:12 CET STATEMENT:
select identifier
from film_iso
where value = 'Hi 3200'

Solomon Peachy (pizza)
Sunday, 17 February 2008, 17:33 GMT
I'm working on something else right now, but when that's done I'll fix this bug properly. In the mean time, can you attach the image that breaks, so I can test it out on my end?
Solomon Peachy (pizza)
Sunday, 17 February 2008, 18:22 GMT
Try the attached patch. (on top of the first)
Rolf Cronberg (rolfcronberg)
Sunday, 17 February 2008, 20:15 GMT
It seems to work alright now. Thank you for you effort.

Would you be interested in a translation to Swedish?
Solomon Peachy (pizza)
Monday, 18 February 2008, 00:41 GMT
Cool, I'll commit the patch and close the ticket as soon as that's done.

And yes, I'd love a Swedish translation. The more the merrier...

Loading...