Photo Organizer

Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/flyspray/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core → Import
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority High
  • Reported Version 2.34-rc4
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Photo Organizer
Opened by Grzegorz Saracki (sarak) - 2007-09-20
Last edited by Solomon Peachy (pizza) - 2007-10-18

FS#290 - Invalid upload path

Php files are in /usr/share/photo-organizer/ directory
In config_site.php i set:
$image_repository_path = "/home/services/photo-organizer/repo/";
And when i try to upload image i get:
# xtracting Image Metadata (EXIF) ... done
# Extracting Image Metadata (XMP) ... done
# Extracting Image Metadata (IPTC) ... done
# Copying original image siamki.jpg into repository ... failed.
#

cp /tmp/phpEUVYLs /home/services/photo-organizer/repo///usr/share/photo-organizer/v0000/00000/7_3_orig.jpg

# Cleaning up the mess.

it seems that $new_volume="/usr/share/photo-organizer/v0000/" but i dont know why

This task does not depend on any other tasks.

Closed by  Solomon Peachy (pizza)
Thursday, 18 October 2007, 20:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  After no feedback for nearly a month (and a release in the mean time) I'm treating this as fixed.
Solomon Peachy (pizza)
Thursday, 20 September 2007, 13:20 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Priority (Normal → High)
  • Field changed: Severity (High → Critical)
under /home/services/photo-organizer/repo, check the 'current' symlink, and you'll find that it's screwed up. Remove it, and manually create it by hand ('current' -> 'v0000')

There's apparently some versions of PHP always making symlinks absolute -- but it's inconsistent.

This is actually the final bug holding up the 2.34 release.
Solomon Peachy (pizza)
Thursday, 20 September 2007, 15:21 GMT
svn r1684 in svn has a potential fix. The problem is that my installation of PHP doesn't have this problem, so I can't be sure it's working.

Apply the attached patch to a new installation (before running install.php) and things should work for you.

Loading...