Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To
    Solomon Peachy
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Devel
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by Solomon Peachy - 2006-05-11

FS#18 - Stop using predictable filenames

For things like photo imports, exports, and whatnot, we use predictable sequences in our filenames. These should be properly randomized.

Closed by  Solomon Peachy
2006-06-06 21:05
Reason for closing:  Implemented
Additional comments about closing:  imports, exports, and raw processing all using much safer temporary names. Still some race conditions present, but unfortunately PHP limitations make these impossible to completely eliminate.
Admin
Solomon Peachy commented on 2006-05-21 17:42

-devel uses tempnam() for the intermediate PPM part in raw decodes, but it has a race condition caused by needing to rename the random filename to $filename.ppm. It's still an improvement over -stable, however.

Meanwhile, the photo import and photo export are both unsafe, as they use a serialized directory name.

Admin
Solomon Peachy commented on 2006-06-06 15:52

Fixed the intermediate PPM stuff in -STABLE, r362

Admin
Solomon Peachy commented on 2006-06-06 15:57

Safe bulk import directory creation, r363(stable), r365(devel)

Admin
Solomon Peachy commented on 2006-06-06 21:03

Safe export support. r370 -devel, r371 -stable.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing