CUPS Dyesub Backends

  • Status Closed
  • Percent Complete
    100%
  • Task Type TODO
  • Category Other printers
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version 1.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: CUPS Dyesub Backends
Opened by Solomon Peachy - 2017-03-23
Last edited by Solomon Peachy - 2019-03-26

FS#575 - Investigate Sony B&W Thermal MedSci models

UPD-897MD, UP-X898MD, and so forth

the UP-D898MD appears to be superficially similar to the Mitsubishi models, complete with the 1280 pixel print head (maxing out at 1280x4000ish) and similar adjustment knobs. They may have the same engine under the hood, but they're not likely to be semi-compatible with the Mitsubishi models.

Closed by  Solomon Peachy
2019-03-26 00:48
Reason for closing:  Implemented
Additional comments about closing:  UP-D895 and UP-D897 are fully supported now.
Admin
Solomon Peachy commented on 2017-03-27 16:52

Someone came along asking about the UP-D898MD, but it is not likely they will be able to assist in bringing up a driver (ie supply usb sniffs and test things)

Admin
Solomon Peachy commented on 2018-12-23 23:16
Looks like the UP-D898MD/UP-X898MD wraps their jobs in PJL. Not sure if it's what gets sent to the printer.
Admin
Solomon Peachy commented on 2018-12-29 16:19
They do some sort of funky data encoding; there's less data than an uncompressed L*W*8bpp would require.
Admin
Solomon Peachy commented on 2019-01-30 03:14
On the '897, the actual print size is smaller than the nominal size: 1280x 960 ==> 1280x652 (68%) 1280x1280 ==> 1280x848 (66%) 1280x1920 ==> 1280x1478 (77%) 1280x3840 ==> 1280x2333 (61%) This is confirmed by the datalen = cols * rows in the headers. Ratio is inconsistent, so it can't be due to non-square pixels. Or even intentional padding.
Admin
Solomon Peachy commented on 2019-03-10 14:17
I now have an UP-D897. It actually has a full UP-D895 emulation mode! The sony backend can now dump over printjobs, and I'm finishing up the Gutenprint rendering code. If it works, I'll commit it, and then I'll attempt to get some sniffs to determine if the printer supports status readback.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing