CUPS Dyesub Backends

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Mitsubishi CP-D70 family
  • Assigned To
    Solomon Peachy
  • Operating System All
  • Severity Low
  • Priority Medium
  • Reported Version 1.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: CUPS Dyesub Backends
Opened by Solomon Peachy - 2017-03-16
Last edited by Solomon Peachy - 2017-03-19

FS#562 - Quality problem with the D70 family image processing library

It's most obvious when printing something with a deep black; you'll see it bleed past a bit.

It's worse in Fine, better in SuperFine/UltraFine.

 

Closed by  Solomon Peachy
2017-03-19 23:51
Reason for closing:  Fixed
Additional comments about closing:  commit 400e94 Believe it or not, the problem was that the image was being printed in the wrong direction. It should be bottom-to-top! (Under the hood this required a lot of work!)
Admin
Solomon Peachy commented on 2017-03-16 17:01

Work's underway to find and fix this problem.  It's very slow going though, due to the reverse-engineered nature of this library.

 

So far, four separate bugs in the library have been identified and fixed, yielding (I believe) a slight improvement, but the problem is still visible.  More work is necessary.

Admin
Solomon Peachy commented on 2017-03-17 14:15

Make that five bugs so far:

(2) CalcTTD

(2) CalcHTD

(1) CalcFCC

And the code is being further annotated as I figure out the data flow and algorithms. 

Admin
Solomon Peachy commented on 2017-03-18 02:06

commit c513da1  -- Should improve the D80 in SuperFine mode when rewinding -- depending on the input image, the behavior needed to change.  A whole lot of other cleanups/annotations have also gone into the library, but none of that should have any functional effect yet.

 

Note that the library and backend need to be updated together here due to the API bump.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing