Gutenprint / CUPS Dye-sublimation drivers

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category DNP/Citizen
  • Assigned To
    Solomon Peachy
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Gutenprint / CUPS Dye-sublimation drivers
Opened by Solomon Peachy - 2015-08-26
Last edited by Solomon Peachy - 2019-05-21

FS#538 - Add support for DS80DX

It has all the joy of the DS80, but also supports sheet-fed simplex and duplex operation. It's a veritable mess to support cleanly.

Closed by  Solomon Peachy
2019-05-21 15:11
Reason for closing:  Implemented
Additional comments about closing:  After some bugfixes, it's confirmed fully functional.
Admin
Solomon Peachy commented on 2015-08-27 03:01

Roll operation is identical to the DS80, with a few additional commands to query duplexer status.

Duplex is only supported with Cut media, which has a different set of supported media sizes.

Admin
Solomon Peachy commented on 2015-08-29 00:53

Backend now has a lot of the basic stuff added (status queries, media sanity checking)

Gutenprint proper needs a ton of work still, and nothing ensures correct simplex/duplex codes when using cut media, as that is dependent on the print job itself.

Admin
Solomon Peachy commented on 2015-09-22 21:24

Gutenprint is theoretically ready now.

Admin
Solomon Peachy commented on 2016-06-28 02:17

Found the USB VID/PID.

Admin
Solomon Peachy commented on 2018-05-20 02:17

And programmed it in wrong.  This code has been broken for two years.

Admin
Solomon Peachy commented on 2018-08-08 17:53

Turns out the USB PID was still wrong.  Corrected.  Hopefully getting more feedback soon.

Admin
Solomon Peachy commented on 2018-10-02 22:44

committed a couple of bugfixes

 

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing