Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core → Import
  • Assigned To No-one
  • Operating System Linux
  • Severity Medium
  • Priority Very Low
  • Reported Version Devel
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Photo Organizer
Opened by Maik Wagner - 2013-10-11
Last edited by Solomon Peachy - 2013-10-18

FS#503 - Importing images fails / Images are not being processed

Dear Developers,

I am very impressed with "Photo Organizer" but I am having importing pictures. I am running openSUSE 12.3 and installed it on my "localhost".

When importing images (I just tried uploading using the browser - Firefox 24 - so far) I get the following errors in my Apache-Log files:

[Fri Oct 11 15:22:30 2013] [error] [client 127.0.0.1] PHP Warning: readlink(): Datei oder Verzeichnis nicht gefunden in /srv/www/htdocs/po/include/import.php on line 70, referer: http://localhost/po/photo.add.php?folder=4
[Fri Oct 11 15:22:32 2013] [error] [client 127.0.0.1] PHP Fatal error: Call to undefined function mb_detect_encoding() in /srv/www/htdocs/po/include/import.php on line 28, referer: http://localhost/po/photo.add.php?folder=4

Could you point me in the right direction?

Regards,

Maik

Closed by  Solomon Peachy
2013-10-18 12:54
Reason for closing:  Not a bug
Additional comments about closing:  PO requires mbstring, which wasn't installed. Installer now checks for it.
Admin
Solomon Peachy commented on 2013-10-11 19:03

you need the php mbstring extension installed. the po installer should have checked for this..

I have very limited connectivity untl monday, but if you are still having problems then, i will do what i can to help.

Admin
Solomon Peachy commented on 2013-10-14 13:42

As it turns out, the installer wasn't checking for the mbstring extension. I've just fixed that.

Meanwhile, are you still having problems? (btw, under Fedora/RHEL, the package you need is 'php-mbstring')

Also, I recommend you use the -devel source rather than the last stable release. It's mostly a bunch of bugfixes and theme improvements.

Maik Wagner commented on 2013-10-14 19:01

Hello Solomon,

thanks for your quick answer. I mainly tinkered around with "Photo Organizer" at my holiday place and currently do not have access to it anymore but will keep trying. I will probably also use RHEL or CentOS then. Is this also a distribution you would recommend for Photo Organzer. I am thinking about offering professional services around this product and probably need something with long-term support for bugfixes anyway.

Thanks again for your help.

Admin
Solomon Peachy commented on 2013-10-15 12:48

As a note, PO doesn't require Fedora or RHEL/CentOS; The former is what I use, and I'm simply not familiar with the package names that Debian/Ubuntu/whatever uses so it's hard for me to provide support on those platforms.

As for the professional services; good luck! PO could use some third-party interest these days..

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing