Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category User Interface
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version 2.37
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by Holger Stephan - 2011-05-15
Last edited by Solomon Peachy - 2011-11-23

FS#450 - wrong real name display in "I am a client of the following users" in users.php

Assume, I am a client "adent" subscribed to one user "fprefect".
When viewing "My Folder", i.e. user.php?user=adent,
at the bottom it says:

I am a client of the following users
User status registration date
Dent, Arthur Accepted May 9, 2011

As far as I understand the source, this is because the function "display_protected_photographers" gets its information from the db view "view_client", which contains real name data from the client of that client-relation; instead of the user of the client relation. This is because in the where clause of "view_client" it says "client.client = users.identifier".

This problem did no arise in 2.35, where "display_protected_photographers" used the db view "view_users_subscribed_to", that does nearly the same as the new "view_client" but stated "client.users = users.identifier".

Regards,
Holger

Closed by  Solomon Peachy
2011-11-23 15:38
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate.
Holger Stephan commented on 2011-05-15 20:50

duplicate of FS#443

sry for that.

Holger

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing