Photo Organizer

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend / Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 2.37
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Photo Organizer
Opened by Andreas Wallberg - 2011-01-24
Last edited by Solomon Peachy - 2013-01-08

FS#448 - How to specify socket at installation if more than one postgres server running?

Hi all!

What a nice project! I am very eager to get this up and running. I am trying to set up the current version of Photo Organizer on my Synology NAS and had to install a separate ipkg version of postgres to be able to do "createlang" at the installation step (the "native" version seems to lack some things).

I now have two postgres instances running, the native one on port 5432 and socket /tmp/.s.PGSQL.5432 and the new one on port 5433 and socket /tmp/.s.PGSQL.5433. I can connect to both at the same time on the CLI and with phpPgAdmin using either the socket or 127.0.0.1, but not at all with Photo Organizer. I get this error:

"Database connection failed; Are credentials valid?"

My "config_site.php" has:

$db_dsn = "host=127.0.0.1 port=5433 dbname=po_db user=po_user password=passwordgoeshere";

I have tried without the host and port specifications and with my postgres user as well. My "pg_hba.conf" is set to prompt for "password" for all connections.

Is there a problem in the code with regards to multiple sockets on a single machine? How can I move forward?

Closed by  Solomon Peachy
2013-01-08 18:54
Reason for closing:  Not a bug
Additional comments about closing:  This isn't a bug in PO. PHP's PG bindings should support this. For example, see: http://php.net/manual/en/function.pg-con nect.php#93837 But if it doesn't work, there's nothing I can do about it in PO's code.
Admin
Solomon Peachy commented on 2011-01-25 00:33

Hmm, looking at the documentation for pg_connect, there doesn't seem to be a way to specify the path to the socket.

However, the postgres docs seem to indicate that you can just say "host=/tmp/.s.PGSQL.5433"

Does that work?

Andreas Wallberg commented on 2011-01-25 21:21

Nope. Same error. Does that socket specification work for you?

Is there something else I should check?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing